Issue Setting Up DyDx v4 Indexer Node

Hi DyDx team,

I am currently facing an issue while trying to set up a DyDx v4 indexer node by following the instructions provided in the official guide at v4-indexer-setup.

I have successfully configured all services as per the guide and upon inspecting the logs, I did not find any errors. However, when attempting to access the API endpoint provided by the comlink service, I encountered the following error:

GEOBLOCKED: Because you appear to be a resident of, or trading from, a jurisdiction that violates our terms of use, or have engaged in activity that violates our terms of use, you have been blocked. You may withdraw your funds from the protocol at any time.

It’s worth noting that I am accessing the setup from a server provisioned in the Germany region.

I would greatly appreciate any assistance or insights into resolving this issue. Additionally, I would like to understand why the postgres container does not seem to be populated with data from the chain.

1 Like

Hi there,

Thank you for reaching out. It seems like you’re encountering a geoblocking error when accessing the API endpoint.

If you are setting up the node for development purposes, you can disable the geoblocking feature in Comlink. To do this, set the INDEXER_LEVEL_GEOBLOCKING_ENABLED environment variable to false. This should bypass the geoblocking restriction and allow you to access the API endpoint.

1 Like

How did you solve the problem of data not populating on postgres ??